tracker issue : CF-4202030

select a category, or use search below
(searches all categories and all time range)
Title:

getApplicationMetaData() broken

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/Fixed

Reporter/Name(from Bugbase): Philipp Cielen / ()

Created: 04/18/2018

Components: Functions

Versions: 2018

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF 2018 public beta 1 / 308558

Priority/Frequency: Normal / All users will encounter

Locale/System: German / Windows 10 64 bit

Vote Count: 0

Today I have installed the ColdFusion 2018 public beta and replaced the previous beta release with it. After installation the ColdBox 5 framework was broken, CF threw an error when trying to set a variable:

var appSettings = getApplicationMetadata();

For whatever reason dumping getApplicationMetadata() worked fine. However it only worked once - trying to dump it twice on the same page or assigning it to a variable resulted in an error.
 
Similar errors have been reported on the bug base (CF-4198394, CF-4198397) but are marked as fixed .

After verifying the bug I uninstalled the current public beta and replaced the installation with the previous version (from the closed beta) and it worked fine again. The current and previous beta release was reinstalled twice to verify that this bug only occurs with the latest beta (same code/same server configuration).

How to reproduce: Install a ColdBox 5 application on the current beta release server and it should break right away.

Attachments:

Comments:

ColdBox 5 framework works with update1 over CF2018 beta release. https://coldfusion.adobe.com/discussion/2480364/    Closing the bug.
Comment by Nitin K.
27445 | April 25, 2018 11:53:35 AM GMT