tracker issue : CF-4202894

select a category, or use search below
(searches all categories and all time range)
Title:

[ANeff] Bug for: CF installer's wsconfig flow

| View in Tracker

Status/Resolution/Reason: To Fix//BugVerified

Reporter/Name(from Bugbase): Aaron Neff / ()

Created: 06/16/2018

Components: Installation/Config, Connector

Versions: 13.0

Failure Type: Usability Issue

Found In Build/Fixed In Build: 2018.0.0.310409 /

Priority/Frequency: Trivial / All users will encounter

Locale/System: / Windows 10 64 bit

Vote Count: 0

Issue: CF installer's wsconfig flow

Copying my comments from Slack:
-----------
Just noticed wsconfig is no longer integrated into CF's installer in this refresh build. I just tiredly clicked my way thru the screens, then went to hit a page and got error. Then noticed site wasn't configured, and recalled that I was never prompted to config a web server. Uninstalled the refresh build and re-ran the installer, to make sure I wasn't missing something. Then I see the message saying wsconfig must be ran post-install now. Serves me right for clicking too fast I guess =P

I'm used to not even reading the description box on [the "Select Installation Directory"] screen. I mean, it's just asking for a path. Guessing that may trip some ppl up..

I'd suggest replacing everything on [the "Configure Web Servers/Websites] screen, w/ that new message. At least for CF2018 and possibly CF2018+1, until people are used to this new flow?

Or just leave [the wsconfig integration] in, if they've selected Developer Edition? Perhaps that's already the case - not sure. I chose the trial. IMO, [the "Configure Web Servers/Websites] screen should perhaps just have a 'skip' option, so ppl installing for dev purposes can install-n-go?
-----------

Attachments:

Comments:

Hi Adobe, Please see attached images. !IMPORTANT! - Developer Edition's installer flow should remain same as pre-Aether w.r.t. wsconfig. Thanks!, -Aaron
Comment by Aaron Neff
29064 | June 16, 2018 08:37:50 PM GMT
Changing the Developer Edition workflow, at this moment is not possible as the installer workflows are freezed.  We will get the Release Notes updated with this new change.
29090 | June 19, 2018 09:23:20 AM GMT
Hi Hari, Thanks very much, but what sense does it make to require manual wsconfig or Auto-Lockdown when installing CF as developer edition? That's a turn off. Making a simple thing complicated. Do you see what I mean? Installing Developer edition and configuring a site should be a simple/smooth process using only the CF installer. Can Adobe please reconsider? Maybe in next updater? Thanks!, -Aaron
Comment by Aaron Neff
29347 | July 15, 2018 08:47:15 AM GMT
Wish I could edit. Please ignore the "Maybe in next updater?" as that doesn't even make sense. Issue should be fixed in next refresh of the installers. The Developer Edition installer flow should not have been changed in CF2018. One doesn't typically lockdown one's Dev edition. Just production. Thanks!, -Aaron
Comment by Aaron Neff
29348 | July 15, 2018 09:20:33 PM GMT
Hi Adobe, I received an email saying: ----------- Issue - https://tracker.adobe.com/#/view/CF-4202894 Target Version updated to 'Alpha' ----------- What does 'Alpha' mean? CF2020 Alpha? CF2018 Update 1 Alpha? I'm confused.. Thanks!, -Aaron
Comment by Aaron Neff
29506 | August 16, 2018 09:17:20 AM GMT
Hi Adobe, The current "Priority:Trivial" holds true for experts but not for new CF developers. Developer Edition installer should be simple for new developers. It was. No longer. Thanks!, -Aaron
Comment by Aaron Neff
29704 | September 17, 2018 03:20:06 AM GMT
08/16/2018 09:17:20 GMT question unanswered..
Comment by Aaron Neff
29705 | September 17, 2018 03:22:33 AM GMT