tracker issue : CF-4203075

select a category, or use search below
(searches all categories and all time range)
Title:

[ANeff] Bug for: debug output completely broken

| View in Tracker

Status/Resolution/Reason: To Fix//HaveNewInfo

Reporter/Name(from Bugbase): Aaron Neff / ()

Created: 07/15/2018

Components: Debugging, General

Versions: 2016,11.0,13.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: 2018.0.0.310739 /

Priority/Frequency: Normal / Some users will encounter

Locale/System: / Windows 10 64 bit

Vote Count: 0

Issue: debug output feature is completely broken

Repro:

1) Enable "Enable Request Debugging Output" in CF Admin
2) Choose dockable.cfm or classic.cfm

Actual Result: When hitting a CF page, debug output is not displayed

Expected Result: When hitting a CF page, debug output is displayed

Attachments:

Comments:

@Aaron  We tried the following: 1."Enable Request Debugging Output" with classic.cfm it worked fine for us,  2. "Enable Request Debugging Output" with  dockable.cfm  in the browser clicking on  "Debug this page" link worked fine, but clicking on "docked debug pane" was showing an blank page (This was the only issue we could see.) If you were trying anything different or hitting any other issue here, please let us know. This issue exists in CF2016 latest as well.  
Comment by Dattanand M Bhat
29328 | July 17, 2018 10:07:47 AM GMT
Hi Dattanand, Sorry! I'd forgotten to add my machine's IP on the "Debugging IP Addresses" page. I'm testing from the same local PC where CF's installed, and that page does allow 127.0.0.1. BUT, that PC has its IP statically assigned. That trips me up sometimes when testing on multiple local PCs =P Now, classic.cfm works perfect. Thanks! Regarding dockable.cfm's , I see 3 issues: 1) After closing the pop-up, clicking "_debug this page_" does nothing (it should re-open the pop-up) 2) If IIS site doesn't have CFIDE virtual directory, clicking "_docked debug pane_" throws 404 (CFIDE virtual directory shouldn't be required) 3) If IIS site does have CFIDE virtual directory, clicking "_docked debug pane_" displays blank page So #1 and #2 are additional issues. You're seeing the pop-up re-appear when clicking "_debug this page_"? Thanks!, -Aaron
Comment by Aaron Neff
29329 | July 17, 2018 06:59:11 PM GMT