tracker issue : CF-4203320

select a category, or use search below
(searches all categories and all time range)

Caching not working

| View in Tracker

Status/Resolution/Reason: To Fix//Investigate

Reporter/Name(from Bugbase): Jürgen Wittsiepe / ()

Created: 09/05/2018

Components: REST Services

Versions: 2018

Failure Type: Others

Found In Build/Fixed In Build: 2018.0.0.310739 /

Priority/Frequency: Normal /

Locale/System: / Win 2016

Vote Count: 0

Problem Description: When I use trused cache REST services are no longer working when the cache is cleared. I only get a blank page.

Steps to Reproduce: Build a workin REST service, active trusted cache, clear cache

Actual Result: blank page

Expected Result: working REST service

Any Workarounds: No



Hi Jürgen, I tried to reproduce the issue on my local Win Server 2016 system. But i am not able to reproduce at my end. Steps Followed by me: 1) Registered REST Service. Ensured that they work. 2) Enabled 'Trusted cache' checkbox. Ensured that the service works. 3) Cleared Cache by pressing each of the buttons 'Clear Trusted Cache Now', 'Clear Template Cache Now' & 'Clear Query Cache Now' in the Caching page of Administrator.    After this the REST Service continued to work as before. Below are the Caching settings i have in my CF Administrator :  |[Caching|http://localhost:8500/CFIDE/administrator/settings/caching.cfm]| |Template cache size|1024 templates | |Enable trusted cache|Yes  | |Cached query limit|100| |Save Class Files|Yes  | |Caching engine|Ehcache  | |JCS DSN name| | |Is JCS cluster enabled|No  | |Memcached servers| | |Redis server| | |Redis port|0  | |Redis cluster enabled|No  | |Custom caches| |   Do you find any thing differing here ? Can you confirm that the same set of caching settings you have in the Administrator ? Additionally if you can provide us the REST Service, it might be helpful in nailing down the issue.  Thanks, Nitin
Comment by Nitin K.
29676 | September 10, 2018 07:32:30 AM GMT
Hi Nitin, I have attached my cache settings. CF-Version is now 2018.0.01.311402. At the moment the problem did not occur when I clear the cache by pressing the buttons mentioned above, but it is still there after a reboot of the server. I see only a white page. Whein I reinitialize the rest service it is running as expected. Jürgen
Comment by Jürgen W.
29699 | September 12, 2018 12:25:16 PM GMT
I am still not able to reproduce with the same Caching settings as you in CF2018 Administrator.  Can you help me with below information:  1) Browser Network call shows any error ? If yes either screenshot/error details needed 2) Are you testing the RESTful API in REST Playground application? 3) Which HTTP verbs you have in your REST Application. Any parameter/header/authentication these endpoints accept. (OR if you can provide us a sample REST Service which you are using) 4) Is this a cross domain request ? Are you getting correct response if you hit the endpoint directly from browser/ other clients (if you have) ?
Comment by Nitin K.
29721 | September 19, 2018 06:29:31 AM GMT
Hi Jürgen, I am waiting for your response.  I tried on other versions of Windows as well and couldn't reproduce the issue. This could be system specific. Can you check in any other setup (if you have)?  It doesn't seem to be REST specific to me. Thanks, Nitin 
Comment by Nitin K.
29745 | September 28, 2018 05:13:37 AM GMT
Hi Nitin, at the moment the problem does no longer occur when I clear the cache. But it is still present when I restart the ColdFusion 2018 Application Server service. Jürgen
Comment by Jürgen W.
29746 | September 28, 2018 06:55:06 AM GMT
Hi Jürgen, Thanks for your response. I do not see the issue faced by you even after server restart. It certainly would be helpful for us if you can answer four questions asked before. Would it be possible for you to connect over a meeting to discuss further on this issue?  Nitin
Comment by Nitin K.
29764 | October 08, 2018 07:09:24 AM GMT
Hi Nitin, yes, we can connect over a meeting. Jürgen
Comment by Jürgen W.
29765 | October 08, 2018 07:31:43 AM GMT
Hi Jürgen, Let me know your preferred time to connect with you on any weekday (b/w 9:00AM & 5:00 PM IST) . Thanks, Nitin  
Comment by Nitin K.
29784 | October 12, 2018 07:01:16 AM GMT
Hi Nitin, Because there is a time difference of 3,5 h between India and Europe it would be possible between 1:00 PM and 4:00 PM (IST). I would recommend a meeting on Tuesday, 23rd at the earliest because I am on holiday from tomorrow on. Jürgen
Comment by Jürgen W.
29785 | October 12, 2018 01:57:36 PM GMT
Hi Jürgen, Let's meet tomorrow then. I will send you a meeting invite (bluejeans) on your mail [|] to understand and see the the environment where this issue is occurring. Thanks, Nitin   
Comment by Nitin K.
29787 | October 16, 2018 09:17:44 AM GMT
Hi Jürgen, I have sent you the meeting invite for today (3:30 PM IST) Nitin 
Comment by Nitin K.
29794 | October 17, 2018 06:36:09 AM GMT
Hi Jürgen, I just noticed that the mails from you were sitting in the junk folder of mailbox. Will reschedule a meeting on 23^rd^ or 24^th^ of October.   Nitin
Comment by Nitin K.
29795 | October 17, 2018 10:19:01 AM GMT
That would be OK. Jürgen
Comment by Jürgen W.
29822 | October 23, 2018 06:43:52 AM GMT
Let’s meet on 25th Oct'18 at 3:30 PM (IST) for this issue. Meeting invite sent to you over email.
Comment by Nitin K.
29831 | October 24, 2018 05:35:01 AM GMT
Hi Nitin, I have build a minimal rest service which shows exactly the same behaviou. Jürgen
Comment by Jürgen W.
29845 | October 25, 2018 11:33:41 AM GMT
It does not reproduce as is on my setup even with the attached REST Service.  Moving the bug to Dev queue to investigate further on the issue.
Comment by Nitin K.
29871 | October 29, 2018 06:28:23 AM GMT