tracker issue : CF-4203345

select a category, or use search below
(searches all categories and all time range)
Title:

Unable to parse API Manager config file. wsconfig on Linux

| View in Tracker

Status/Resolution/Reason: Open//

Reporter/Name(from Bugbase): Peter Freitag / ()

Created: 09/18/2018

Components: API Manager, Connector

Versions: 13.0

Failure Type: Incorrectly functioning

Found In Build/Fixed In Build: 2018.0.0.310739 /

Priority/Frequency: Normal / Most users will encounter

Locale/System: ALL / Linux

Vote Count: 0

Problem Description: Running wsconfig on a linux server, getting an error "Unable to parse API Manager config file."

Steps to Reproduce: Installed api manager 2018 and started apimanager on a CentOS Linux release 7.5.1804 server. Tried to run wsconfig using the following: 

wsconfig/wsconfig -ws Apache -dir /etc/httpd/conf -bin /usr/sbin/httpd -vhost All 

The contents of conf/cluster.xml is:

<?xml version="1.0" encoding="UTF-8"?><Cluster>
<context>
<portalcontext>/</portalcontext>
<proxycontext>/</proxycontext>
</context>
</Cluster>

I have not modified any of the config xml files after installing. 

Actual Result: "Unable to parse API Manager config file."

Expected Result: configures the connector.

Any Workarounds: no

Attachments:

Comments: