tracker issue : CF-4204032

select a category, or use search below
(searches all categories and all time range)

unable to stat error logged in mod_jk.log

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/Fixed

Reporter/Name(from Bugbase): Annie Chellah T. / ()

Created: 02/18/2019

Components: connector

Versions: 2016

Failure Type: Incorrectly functioning

Found In Build/Fixed In Build: 2018,0,02,313961 / CF2018U4

Priority/Frequency: Normal /

Locale/System: / Linux Red Hat All

Vote Count: 1

Problem Description:
As soon as ColdFusion 2018 update 2 was installed and the Apache connector was rebuilt, we are seeing this following error in mod_jk.log, repeatedly.
[Thu Feb 14 12:42:06 2019] [16186:139977799252096] [error] uri_worker_map_update::jk_uri_worker_map.c (1299): Unable to stat the /opt/coldfusion2018/config/wsconfig/1/ (errno=13)
The server is running RHEL 7, with SELinux and locked down. However the apache is running without any issues and the web application doesn't experience any issues. But the mod_jk.log is flooded with this entry.
It would be great, if someone could assist on this please. We didn't face this issue before.

But the issue was solved by granting 660 as opposed to 540, recommended in CF2018 lockdown guide.

Please look into this issue. 

Steps to Reproduce: After installing update 2, apache connector is removed and re-installed. The issue occurs when the file permissions are changed to 540 as per CFLockdown guide. 

Actual Result: Apache starts up okay but there's this error message, constantly logged in mod_jk.log

[Thu Feb 14 21:25:01 2019] [1491:140393088891008] [error] uri_worker_map_update::jk_uri_worker_map.c (1299): Unable to stat the /opt/coldfusion2018/config/wsconfig/1/ (errno=13)

Expected Result: No error message. 

Any Workarounds: Granting write permissions to the file or to the directory /opt/coldfusion2018/config/wsconfig/1



I'm seeing this issue as well, unfortunately for me changing the permissions on the folder structure isn't making the error go away. I've tried setting the entire folder and all files to 777 just to see if that would fix it, but it does not. I've also tried setting the SELinux context to each of the following (at different times) to no avail: chcon -t httpd_config_t -u system_u /opt/coldfusion2018/config/wsconfig/1/ chcon -t httpd_sys_rw_content_t -u system_u /opt/coldfusion2018/config/wsconfig/1/ I've even tried disabling SELinux to see if that resolves the issue and it does not. Why would it be trying to write to this file anyway?
Comment by Dan S.
30653 | April 24, 2019 12:49:39 PM GMT
Vote by Dan S.
30654 | April 24, 2019 12:50:05 PM GMT
I would check if the right ownership is granted as well. The group should be user group in which CF is installed and also the apache user, so that it's able to stat it. I think apache threads are not trying to write in it, probably its attempting to retrieve information about the file. I believe, stat is a system call. Hope this helps. Thanks for upvoting the issue.
Comment by Annie T.
30662 | April 26, 2019 12:12:02 PM GMT
Thanks for the suggestion. Unfortunately, I've made sure the entire directory tree has the correct ownership. The ownership of the mod_jk.log is the same, and Apache is able to write to that file just fine (because that's how I know about the errors).
Comment by Dan S.
30663 | April 26, 2019 12:44:58 PM GMT
That's really strange. This ticket is closed. Do you think, its best a new ticket be opened for the same?
Comment by Annie T.
30664 | April 26, 2019 02:47:17 PM GMT