tracker issue : CF-4204044

select a category, or use search below
(searches all categories and all time range)
Title:

CF11 Update16 HTTP connection failure

| View in Tracker

Status/Resolution/Reason: To Fix//BugVerified

Reporter/Name(from Bugbase): Scott S. / ()

Created: 02/22/2019

Components: Language, Tags

Versions: 11.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: 11,0,17,314003 /

Priority/Frequency: Normal /

Locale/System: / Win 2012 Server x64

Vote Count: 1

Problem Description:
When making an http GET or POST to an external url, we are getting a Connection Failure. We notice this with many of the credit card payment gateways we connect to. Tried reinstalling their SSL certs in the Keystore, but that did not change anything.

Steps to Reproduce:

Actual Result:

Expected Result:

Any Workarounds:
Reverted back to Update 15

Attachments:

Comments:

We have also experienced this. It seems to be caused by a change in behavior of the cfhttpparam tag. When using cfhttp to make a GET request and using cfhttpparam to add query string parameters. Updates 16 and 17 inconsistently encode values. For example, update 15 and below correctly encode the value % to %25 always. Updates 16 and 17 don't always encode the values. The behavior appears to depend on the combination of characters present in the value. When the value is not encoded ColdFusion fails with a connection failure error. This failure appears to happen prior to the request actually being made.
Comment by Bob G.
30399 | February 26, 2019 06:04:48 PM GMT