tracker issue : CF-4204714

select a category, or use search below
(searches all categories and all time range)

jetty/lib directory missing after applying CF2018 update 2 and later

| View in Tracker

Status/Resolution/Reason: To Fix//BugVerified

Reporter/Name(from Bugbase): Shigeyoshi M. / ()

Created: 07/09/2019

Components: Hot Fix Installer

Versions: 2018

Failure Type: Non Functioning

Found In Build/Fixed In Build: 2018,0,04,314546 2018,0,03,314033 2018,0,02,313961 /

Priority/Frequency: Normal /

Locale/System: / Win 2016

Vote Count: 0

When applying update under following 2 conditions, jetty/lib folder is moved to backup folder of update.

1. PDFG service is not included in Jetty:
    'PDFgServlet' folder is not in [cf_root]\cfusion\jetty\webapps\

2.'jetty' folder is not included in backup folder of update:
   'Jetty' folder is not in [cf_root]\cfusion\hf-updates\hf-2018-0000X-XXXXXX\

Above 2 conditions can be applied to, for example, when a user does not select 'PDFG Service' as Sub-components at installation.
Then, a user firstly apply the update 2 or higher, jetty/lib directory is wrongly moved to backup folder of update, the ColdFusion 2018 Add-on Services fails to start on each of the servers.

Below is quote from log (Adobe_ColdFusion_2018_Update_4_Install_07_02_2019_18_37_43.log) at 16878 lines:

Move Directory:
                          Status: SUCCESSFUL

The behavior is caused by the fixes by ColdFusion 2018 Update 2 for the libraries of 'Jetty' and 'PDFG Service' which are target for deplying and updating files.

Moving Jetty/lib folder manually to the correct postion: [cf_root]/cfusion/jetty/
Or, uninstalling update and install it again. This is worked as solution because jetty folder at backup folder is not uninstalled during uninstallation so that condition 2 is nolonger applied.


When either of above workaround is done, PDFServlet folder is added to [cf_root]\cfusion\jetty\webapps\
This will be also worked as solution as the conditon 1 is no longer applied to.