CacheGetAllIds has inconsistent parameter naming| View in Tracker
Reporter/Name(from Bugbase): Kama S. / ()
Failure Type: Conflict With Docs
Found In Build/Fixed In Build: 2018,0,04,314546 / 318001
Priority/Frequency: Normal /
Locale/System: / Linux All
Vote Count: 0
The cacheGetAllIds function has its second parameter documented as `accurate`. The named parameter is actually `includeExpired`. The name being different would not normally be a big issue as that could be a documentation fix with the named parameter being used instead, The problem is that semantics of these names are the opposite. The semantically equivalent name of `accurate` would be `excludeExpired`. I've unfortunately been unable to get the second parameter to have an effect on the resulting array in my tests, so I cannot say which is actually correct.