tracker issue : CF-4205219

select a category, or use search below
(searches all categories and all time range)

CFObject in CF 2018 for calling a COM object

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/UserError

Reporter/Name(from Bugbase): LOUIS S. / ()

Created: 09/16/2019

Components: COM/DCOM

Versions: 2018

Failure Type: Non Functioning

Found In Build/Fixed In Build: newest /

Priority/Frequency: Normal / All users will encounter

Locale/System: English / Win 2016

Vote Count: 0

Problem Description:
When calling the activePDF toolkit dll using this:
<CFOBJECT ACTION=”Create” TYPE=”COM” CLASS=APToolkit.Object NAME=”TK”> I get this error:
An exception occurred when instantiating a COM object.
The cause of this exception was that: AutomationException: 0x80040154 – Class not registered.
Steps to Reproduce:
Tried it on 2 different servers.   Works fine with CF11, not in CF18
Actual Result:
It calls a CLSID
Expected Result:
After getting support from activePDF, we found that CF, when trying to load a COM object is looking at a path that doesn’t exist: D:\ColdFusion2018\cfusion\wwwroot\WEB-INF\exception\coldfusion\runtime\com and also this key: HKCR\WOW6432Node\CLSID\{F74F7C81-E3B7-4974-95C6-E487390CCE48} which is not one of their CLSIDs. 
Any Workarounds:
none yet



Louis, What's the update level of the CF2018 you're on. That errors suggests that the DLL is not registered with your OS. did you register it using the regsvr command. Is your CF11 installed on the same host machine as CF2018?
Comment by Piyush K.
31641 | October 17, 2019 02:38:27 PM GMT
Louis, could you pls. revert with the information sought in my previous comment.
Comment by Piyush K.
31759 | November 06, 2019 01:34:58 PM GMT
It was a separate machine. The issue was solved. Priyank helped me and this solved it: Register the TypeViewer.dll, located at {cf-install}/cfusion/lib/ at the command prompt using the command below: regsvr32.exe /s /path/to/dll/TypeViewer.dll
Comment by LOUIS S.
31760 | November 06, 2019 01:40:27 PM GMT