tracker issue : CF-4206425

select a category, or use search below
(searches all categories and all time range)

cfpdf action="merge"

| View in Tracker

Status/Resolution/Reason: To Track//PRNeedInfo

Reporter/Name(from Bugbase): Thomas Z. / ()

Created: 12/18/2019

Components: Document Management, PDF generation

Versions: 2016

Failure Type: Data Corruption

Found In Build/Fixed In Build: ? /

Priority/Frequency: Normal / All users will encounter

Locale/System: English / Win 2016

Vote Count: 0

Problem Description:
This is the offending line:
                <!--- Line that stopped working after upgrade to 2016 TBZ --->
    <cfpdf action="merge" destination="reports/#reportName#.pdf" overwrite="yes">
                                <cfloop from="0" to="#pdfIndex#" index="j">
                <cfpdfparam source="reports/#reportName#_#j#.pdf" pages="1">
It worked previously – now it creates a file with only the _0 file.

I have tried to flatten the files first – that failed.
Instead of a loop I manually entered the file names – it still didn’t create the pdf from all the individual pdfs, it only used one.
I created a folder and instead of a loop – I used a command to merge everything in the folder, it resulted in a document with the same number of files but only used one of them – page 8 this time.

Steps to Reproduce:

Actual Result:

Expected Result:

Any Workarounds:



The merge problem was resolved after commenting out: <cfpdf source="#session.reportsDir#\#reportName#.pdf" destination="#session.reportsDir#\#reportName#.pdf" action="write" flatten="yes" overwrite="yes" >
Comment by Thomas Z.
32016 | December 18, 2019 06:52:39 PM GMT
Hi,   Can you attach 2-3 sample PDF's which you were trying to merge? Can you also share the PDFs before flattening and after flattening? This will help us in narrowing down the isssue   Thanks, Kailash
Comment by Kailash B.
32017 | January 23, 2020 08:55:47 AM GMT