tracker issue : CF-4206902

select a category, or use search below
(searches all categories and all time range)

Cannot change 'Request Limits' / Error: Cannot find attribute [maxThreads]

| View in Tracker

Status/Resolution/Reason: To Track//PRNeedInfo

Reporter/Name(from Bugbase): MICHAEL W. / ()

Created: 01/28/2020

Components: Administrator

Versions: 2018

Failure Type: Incorrectly functioning

Found In Build/Fixed In Build: 2018.0.05.315699 to 2018,0,07,316715 /

Priority/Frequency: Normal / Some users will encounter

Locale/System: English / Win 2012 Server x64

Vote Count: 1

Problem Description:
Up to Hotfix 4 OK but with Hotfix 5 or higher it is not possible to change 'Maximum number of simultaneous Template requests' in CF-Administrator/Request Tuning/Request Limits:
By clicking to 'Submit changes' the info will show: 'Server has been updated successfully' but the page refreshes with the old value. Same time there is an error in the server.log:

"Error","http-nio-8500-exec-1","01/27/20","18:14:27",,"Cannot find attribute [maxThreads] on resource []"

Linux or Windows with Developer Edition, there is no Error
Windows with Standard Edition --> Error (Same error on two different Systems)

Steps to Reproduce:
CF10 was installed, CF 2018 Installed with Migration Wizard

Actual Result:

Expected Result:

Any Workarounds:



@Michael this issue is been fixed in CF2018HF7. Please try updating the CF server to (2018.0.07.316715), let us know if you still face this issue.
Comment by Dattanand M.
31972 | January 29, 2020 05:15:19 AM GMT
Hello No, it does not work with HF7 - i referenced to that in the "Found In Build" option of the Bug-Details Is there something that i can manually change? Regards
Comment by MICHAEL W.
33143 | February 18, 2020 08:06:06 AM GMT
I can confirm experiencing the same problem in CF2018 with update 7, and I will add that I confirmed I had NOT done any migration of prior settings (I did not see any migration log in my cfusion/logs). And FWIW, I can confirm that changing the maxthreads value for the ajp connector in CF's cfusion/runtime/conf/server.xml will indeed cause the value to change in the Admin. (Beware, it will reflect the change immediately, without a restart. But again that has no impact on the underlying neo-runtime.xml requestLimit value, which is what this admin page SHOULD be showing.) Of course, that's it's own long-standing problem (since CF10), that in STANDARD ONLY CF mistakenly (I assert) pulls in that maxthreads value and shows that here in the max simultaneous requests. These are NOT the same values. The latter is how many requests CF will run at once before queuing them, the former is how many connections the AJP connector will maintain (whether for running or completed requests, until the connectionTImeout is reached for each thread). I can't believe that problem has not been solved in all these years, but I don't know if a bug was ever filed for it. Can anyone from Adobe confirm? (The search UI for tracker is dreadful. I understand you have your own more powerful search tool.)
Comment by Charlie A.
33153 | February 18, 2020 07:54:55 PM GMT
I am unable to check the request limit on CF Standard 2016 either. Changing it via neo-runtime.xml also has no affect on the number shown in the CFADMIN! So where do we change it from?
Comment by BROOK D.
33154 | February 18, 2020 08:31:42 PM GMT
If I change this line in server.xml: <Connector protocol="HTTP/1.1" port="8585" redirectPort="8449" maxThreads="10" connectionTimeout="20000"/> It reflects in the CFADMN request limit setting - is that what it is supposed to do? On 2016 Standard, changing the AJP connector in server.xml does not reflect a change in the CFADMIN...
Comment by BROOK D.
33155 | February 18, 2020 08:34:31 PM GMT
OK, so this is getting weird. First, Brook, it had never occurred to me to try to change/add a value for maxthreads for the non-AJP connector (that http/1.1 one is for the CF built-in web server). But I can confirm that if I set a value there, than that DOES appear in the CF Admin UI (in Standard, on CF2018 u7) for the max simult requests. But then you say Brook that changing the AJP connector does NOT result in that change appearing in the UI. Well, I can confirm that I have now found that if you DO have a value for maxthreads in that http/1.1 connector, then that in effect OVERRIDES CF's looking to the maxthreads of the ajp connector. Try it yourself, Brook. Take OUT that maxthreads, and save the file, and even without restarting CF, you will see that on refreshing the Admin, it should now show what is set on the AJP element. And FWIW, I had NO maxthreads on my http/1.1 connector (and I don't think there is one there by default ever in CF), so that may explain why you had the sense (Brook) that changes to the AJP connector maxthreads were not coming up. So this suggests that something changed where either Adobe IS now looking at that http/1.1 connector to use its value of maxthreads (if there, else it uses the ajp one), or they changed something to now put a maxthreads there (making it respond this way). But all this again is in my mind a mistake on Adobe's part. It has NEVER made sense that CF Standard (only) even BOTHERS to look at the maxthreads value. IT does NOT do that in Enterprise/Trial/Dev. Can we either get this changed, or get someone to explain WHY it happens? Dattanand? One last thing: if anyone reading along tries fiddling with these knobs, do beware that the server.xml file is indeed case-sensitive, so if you write maxthreads rather than maxThreads, you will find that CF will start but you won't be able to run any CF requests.
Comment by Charlie A.
33156 | February 18, 2020 10:27:19 PM GMT