tracker issue : CFB-3754039

select a category, or use search below
(searches all categories and all time range)

SQL Editor DSN drop down broken if it can't connect initially

| View in Tracker

Status/Resolution/Reason: To Fix//

Reporter/Name(from Bugbase): Raymond Camden / cfjedimaster (Raymond Camden)

Created: 05/02/2014

Components: Editor Features

Versions: 3.0

Failure Type: Incorrect w/Workaround

Found In Build/Fixed In Build: PublicBeta /

Priority/Frequency: Normal / Some users will encounter

Locale/System: English / Platforms All

Vote Count: 0

I launched CFB with CF11 NOT running. I right clicked on a query, did SQL editor, and the DSN dropdown was blank. This is to be expected as CFB could not speak to CF11.

I then started CF11, confirmed DNSs showed up in the RDS database view.

I then right clicked in a query again and the dropdown was still blank. I tried the Refresh button but it didn't work. I had to shut down and restart CFB.

NOTE! The bug form here still doesn't show FINAL as a build!

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3754039

External Customer Info:
External Company:  
External Customer Name: cfjedimaster
External Customer Email:  
External Test Config: My Hardware and Environment details:



We are not able to reproduce this issue. Are you sure the server is associated with the project you are working on? (Comment added from ex-user id:dsarkar)
Comment by Adobe D.
27104 | May 06, 2014 12:39:38 AM GMT
I'm not sure how else I can describe it, but I just recreated it again. So, to be clear: I've got CF11 on my laptop. It is NOT running. I launch CFB. I right click in a query and select SQL editor. The DSN drop down is blank. This is expected - it couldn't use RDS to hit the server. I start CF11, I confirm CFB can use RDS by expanding the server in the RDS panel. The DSNs show up. Back in the editor, I right click again, SQL Editor, and the drop down is blank. If need be I can record a video.
Comment by External U.
27105 | May 06, 2014 06:52:40 AM GMT
Btw - why was this bug closed? I understand you couldn't reproduce it, but you should have waited for me to respond at least.
Comment by External U.
27106 | May 06, 2014 06:53:12 AM GMT
Adobe are good at this Ray, you should know that by now. Anyway if it is any consolation, I was able to replicate it exactly as you said it happened.
Comment by External U.
27107 | May 06, 2014 07:37:01 AM GMT
Apologies, this was closed by mistake. I had updated it in the morning with a note, and then closed it inadvertently while closing another similar bug. I think the issue is about code assist not getting refreshed with dsn server settings once it is connected. This works fine if server is connected at once, but if it is disconnected and then connected, the datasources fail to show up. (Comment added from ex-user id:dsarkar)
Comment by Adobe D.
27108 | May 07, 2014 12:02:40 AM GMT