tracker issue : CFB-3756008

select a category, or use search below
(searches all categories and all time range)
Title:

Home and End keys stop working after a while

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Bradley Wood / bradwood.com (Bradley Wood)

Created: 05/06/2014

Components: Editor Features

Versions: 2016,3.0,3.2

Failure Type: Non Functioning

Found In Build/Fixed In Build: PublicBeta / NA

Priority/Frequency: Normal / Unknown

Locale/System: English / Windows 7 SP1 64-bit

Vote Count: 4

Problem Description:

I haven't been able to find out what the trigger, but I've experienced this probably 10-15 times on the Final build of CFB3 and I think I saw it a few times when I was using the public beta.  Basically, I'll be editing code in a CFC file and suddenly my "home" and "end" keys stop working on my keyboard.  They still work in any other program-- just not in ColdFusion Builder.  I use those keys a LOT when coding to manipulate the cursor so I notice right away.  What's interesting, is HOME and END will still work IF I hold down the shift key to highlight text, but on their own, nothing happens.  If I close and re-open CFBuilder it usually fixes it.

Steps to Reproduce:

It just happens when I'm editing a CFC file.  I haven't figured out the pattern.

Actual Result:

Home and End keys fail to move the cursor to the beginning and end of the line of text.

Expected Result:

Home and End keys move the cursor to the beginning and end of the line of text.

Any Workarounds:

No, just close and reopen the program.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3756008

Reason:	BugVerified

External Customer Info:
External Company:  
External Customer Name: bradwood.com
External Customer Email:  
External Test Config: My Hardware and Environment details:



Windows 7 64-bit

CF Builder Version: 3.0.0

CF Builder Build: 289809

Attachments:

Comments:

I chose "Public Beta" for the build, but only because there is not an option to select the final build.
Comment by External User
27072 | May 06, 2014 04:16:55 PM GMT
Amit, can you please investigate and try to find a repro for this issue. (Comment added from ex-user id:dsarkar)
27073 | May 28, 2014 05:02:12 AM GMT
Can you confirm this on the GM build of Builder (i.e. 289860) ? (Comment added from ex-user id:amkum)
27074 | June 04, 2014 01:27:34 AM GMT
I just updated to 3.0.0.290048 and I'll see if I still encounter the issue . Can you confirm if a fix was actually included for this specific behavior or if you're just hoping maybe it got fixed? :)
Comment by External User
27075 | June 27, 2014 12:09:59 PM GMT
Update, I just encountered the issue again on 3.0.0.290048 so it looks like it has NOT been fixed. Please let me know what other information I can provide to help you.
Comment by External User
27076 | July 02, 2014 04:30:39 PM GMT
Please try the following and let us know if it makes any difference 1) Try escape key when this occurs. 2) Close and open CFC and try again. Also share the error logs if any error occurs . (Comment added from ex-user id:amkum)
27077 | July 09, 2014 01:23:23 AM GMT
Update, the error happened again today. I tried pressing the escape key, but it had no effect. Closing and re-opening the CFC did fix it. I have noticed there is one CFC in particular that experiences the issue more than others. This is a script CFC and has lots of special characters. When editing the a regex the other day in the file, the issue was happening all the time. I think's related to parsing the file. Here is the file if you want to play around with it: https://github.com/Ortus-Solutions/commandbox/blob/master/src/cfml/system/services/CommandService.cfc
Comment by External User
27078 | July 10, 2014 03:29:36 PM GMT
The issue just happened again (in the same file I linked to) closing and re-opening the file did NOT help. I was forced to close Builder entirely and reopen.
Comment by External User
27079 | July 10, 2014 03:38:07 PM GMT
I tried to repro with the linked file but I am not able to repro on my machine. as you see this occuring, please provide us the exact steps to repro this issue. Can you also try to repro this with new workspace . (Comment added from ex-user id:amkum)
27080 | July 21, 2014 07:01:31 AM GMT
I don't have exact steps-- it just happens while I'm typing and moving the cursor. I tend to type quickly while coding and switch quickly between lines to copy and paste-- all with keyboard shortcuts. It's impossible for me to memorize the exact keys I've pressed prior-- especially since I don't notice until I go to use the HOME or END keys. I'll note again that the HOME and END keys still work when holding down the shift key. Perhaps if you review the code, you can find what is handled differently when the shift key is depressed to figure out the difference. I would be willing to use a special build of CF Builder that logged key strokes or logged additional debug information to help track the behavior down. What do I need to do in order to clear the workspace? Delete the .project file?
Comment by External User
27081 | July 21, 2014 02:31:03 PM GMT
please share the configuration you are using and how do you open your file in editor (from File View or RDS File View or Project Explorer etc.)? (Comment added from ex-user id:amkum)
27082 | July 23, 2014 02:43:34 AM GMT
How do I share my config? Also, you didn't tell me how to clear my workspace. I open my files from the "Navigator" view. I have mapped the F8 key to open the view to match HomeSite, Dreamweaver, and SSMS :) I also open a large number of files via the Ctrl+shift+R shortcut. FYI, AJ Mercer also reported on Twitter that he is experiencing this and it happened most recently after the did a copy/paste.
Comment by External User
27083 | July 23, 2014 12:03:57 PM GMT
Thanks! for sharing the information with us. Please confirm this issue with the new workspace by following steps 1. create a new workspace (File -> Switch workspaces -> Other -> new workspace path) and lauch CFB with this new workspace. 2. create new project in the default location and put your CFC files in this project 3. now open cfc in editor and check if it is still happening. are you using CFB as standalone or CFB as plugin to eclipse? (Comment added from ex-user id:amkum)
27084 | July 23, 2014 11:24:49 PM GMT
I am getting the same behaviour with cfEclipse plugin on Aptana Aptana Studio 3, build: 3.5.0.201312191422 Eclipse Platform Version: 4.3.1.v20130911-1000 Build id: M20130911-1000 cfEclipse 1.4.6.R201403180646 Once it happens I have to shutdown and reopen Aptana
Comment by External User
27085 | July 24, 2014 11:49:20 PM GMT
Please confirm this behavior on latest build of cfb3 as standalone or cfb3 as plugin to eclipse (Aptana is not required). [As the aptana dependency has been removed in cfb3. So we are not testing cfb3 on aptana] (Comment added from ex-user id:amkum)
27086 | July 29, 2014 12:39:34 AM GMT
Have you tried CFB3.0? We have re-written CFB codebase in v3 and have done away with Aptana dependency in editor. Please do get back to us on this. We will wait for a couple of days and then if we do not hear back, we will close the bug for now assuming it's no longer a blocking issue. However, you could always open a fresh bug later if you hit upon this or anything similar. (Comment added from ex-user id:dsarkar)
27087 | November 11, 2014 04:34:01 AM GMT
Hi Dipanwita, please re-read the issue description as it includes the version of CB Builder I was using. Also, please reread the comments threads where we discussed the versions I was continuing to see the issue on. I haven't experienced the issue in a while, though it may just be because I haven't been editing much code in the sample file I provided (in the 7th comment) which is large, all-script and prone to cause the issue.
Comment by External User
27088 | November 11, 2014 08:22:47 AM GMT
This is happening to me fairly regularly. I have not detected a pattern in the types of files it happens for. ColdFusion Builder 3.0.0 as a plugin to Eclipse Kepler Service Release 2.
Vote by extuser
27090 | April 06, 2015 09:34:53 PM GMT
Having this happen pretty regularly and it is quite annoying as I use those keys all the time, please fix!
Vote by extuser
27091 | July 09, 2015 08:58:33 PM GMT
I've also had this issue. Closing and re-opening the program fixes the issue, but its very annoying. I've used the same system for a very long time, this seems to have just started for me. I noticed it happens more frequently, when using components written in CFScript.
Vote by extuser
27092 | August 17, 2015 11:08:55 PM GMT
This is probably already known, but I just noticed a detail with this bug not mentioned here. When this occurs and the HOME and END keys stop working in open edit tabs with CFMs and CFCs, they still work in open edit tabs for other types of files, such as XML files, for instance. So the editor as a whole still get HOME and END keys fine, it just seems to ignore them in CFM/CFC editors.
Comment by External User
27089 | August 25, 2015 09:28:05 AM GMT
This has been happening to me with ColdFusion Builder 2016. I have to close CFB and reopen to get the home/end keys to work again.
Vote by extuser
27093 | April 06, 2016 12:55:13 AM GMT
We tried the sample code from url(https://github.com/Ortus-Solutions/commandbox/blob/master/src/cfml/system/services/CommandService.cfc) with ColdFusionBuilder 2018 and could not observe the issue. The 2018 release of ColdFusion Builder comes with Oxygen version 4.7.2, upgraded from Mars.   Please let us know if still observe the issue with ColdFusion Builder 2018 and will reopen the bug. Closing the bug as of now.
Comment by Mukesh Kumar
29902 | November 06, 2018 09:59:49 AM GMT