tracker issue : CFB-4152930

select a category, or use search below
(searches all categories and all time range)

Saving file opened from file system creates duplicate editor

| View in Tracker

Status/Resolution/Reason: To Track//PRNeedInfo

Reporter/Name(from Bugbase): Jake Munson / Jake Munson (Jake Munson)

Created: 05/13/2016

Components: General - IDE

Versions: 2016

Failure Type: Incorrect w/Workaround

Found In Build/Fixed In Build: CFB2016_Final /

Priority/Frequency: Normal / Some users will encounter

Locale/System: English / Windows 7 64-bit

Vote Count: 0

Problem Description: While editing a file opened from the local file system (not from a Project), each time you save the file a duplicate editor is created for the file.

Steps to Reproduce: 
  1. Find a ColdFusion file in Windows Explorer.
  2. Double click the file to open it in CFB.
  3. Make a change to the file.
  4. Save the file.

Actual Result: File is saved, but a duplicate editor is opened within CFB. 

Expected Result: File is saved, no duplicate editor.

Any Workarounds: None...just close the duplicate editor every time you save the page.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4152930

Reason:	PRHaveInfo

External Customer Info:
External Company:  
External Customer Name: Jake Munson
External Customer Email:  
External Test Config: My Hardware and Environment details: ColdFusion Builder 3.1.1. Installed as standalone CFB, not a plugin in Eclipse.



Hi Jake Munson, I tried this on Win 7, 8 builder 3.1.1 standalone. I am unable to repro this issue. Thanks, Dattanand Bhat
Comment by Dattanand M.
26429 | June 02, 2016 11:49:34 PM GMT
Thanks for hte response Dattanand. I have attached 3 files to this bug. The first one (sc1.png) shows that I have one file open, and you can see from the path in the title bar that this is a file that I opened from my C: drive. Then I make a change in the file and save it. The second screen shot (sc2.png) shows the second duplicate editor that was created next to the first one. I also attached a screenshot of my Eclipse Installation Details screen (sc3.png), if that helps.
Comment by External U.
26430 | July 19, 2016 01:23:17 PM GMT
Hi Jake, with reference to the third screen shot attached by you I.e sc3.png seems like you are using CFB2016 Builder as a plug-in ? I tried to repro as stated by you in the description but this time having installed builder as a plug-in to eclipse and applying update2 on top of that, I was still not able to repro this bug. Are you still facing this issue ? Thanks, Dattanand Bhat
Comment by Dattanand M.
26431 | July 28, 2016 04:51:35 AM GMT
Yes, I am still facing this issue. I do not have CFB installed as a plugin, I installed it standalone. I am using Mylyn (from the Eclipse project). That might have something to do with it.
Comment by External U.
26432 | August 09, 2016 10:04:04 AM GMT
@Jake Could you please share with us the screen-shot of the issue that you are facing ?
Comment by Dattanand M.
29843 | October 25, 2018 05:30:09 AM GMT