tracker issue : CFB-4188240

select a category, or use search below
(searches all categories and all time range)

Var keyword breaks code formatter

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/Fixed

Reporter/Name(from Bugbase): Legorol San / Legorol San (Legorol San)

Created: 09/11/2016

Components: Editor Features

Versions: 2016

Failure Type: Non Functioning

Found In Build/Fixed In Build: CFB2016_Update2 / 302510

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Windows 10 64 bit

Vote Count: 0

Problem Description:
When using the code formatter on any file or code block, if any <cfset> tags include the Var keyword, the code formatter does not work. It simply does nothing, does not alter any line of code (not just the <cfset> in question).

Steps to Reproduce:

Create a new CFM file with the code below, then run the code formatter (CTRL-SHIFT-F on Windows, or from menu):
<cffunction name="f">
<cfset x=1>
The code is formatted correctly, e.g. <cfset> gets indented, spaces are put around the = signal.

Next create a new CFM file with the code below, then run the code formatter:
<cffunction name="f">
<cfset var x=1>
The code formatter does nothing, none of the code is changed in any way.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4188240

Reason:	BugVerified

External Customer Info:
External Company:  
External Customer Name: Legorol San
External Customer Email:  
External Test Config: My Environment details:

Windows 10 Anniversary Edition 64-bit, Eclipse Mars.2 Relase (4.5.2), ColdFusion Builder 2016 with update 2 installed as plug-in.



I see that this bug is marked as fixed in CFB 2016 Update 4. I have just installed the update, and unfortunately it's still not fixed properly. Some progress has been made. For example, this code can now be formatted: <cffunction name="f"> <cfset var x=1> </cffunction> However, these code examples still can't be formatted: Example 1: <cffunction name="f"> <cfset var x=1> <cfset var y=2> </cffunction> Example 2: <cffunction name="f"> <cfargument name="y"> <cfset var x=1> </cffunction> Example 3: <cffunction name="f"> <cfset x=1> <cfset var y=2> </cffunction> Please reopen this bug.
Comment by Legorol S.
26125 | May 28, 2017 11:53:10 PM GMT
Hi Legorol and Adobe, In less than 1 minute, I've confirmed the repro cases in Legorol's comment still fail in CFB2018 (Version: 3.2.0; Build: 310721). Adobe, it's been nearly 15 months. Do you have 1 minute to confirm that this ticket isn't fixed? Thanks!, -Aaron
Comment by Aaron N.
29478 | August 12, 2018 05:26:54 AM GMT
Hi Aaron, Thanks for your support. For your reference, I have already opened (13 months ago!) another ticket about this: This is absolutely disgraceful on Adobe's part. The formatter is one of the few features in the paid version of CFB, and is the primary reason why my organisation has bought CFB licences. However, it is completely broken in all but the most trivial cases.
Comment by Legorol S.
29486 | August 12, 2018 12:46:28 PM GMT