tracker issue : CFB-4198456

select a category, or use search below
(searches all categories and all time range)

Source not found, exception in Eclipse .log

| View in Tracker

Status/Resolution/Reason: Open//

Reporter/Name(from Bugbase): Alicia M. / ()

Created: 01/03/2020

Components: Debugger

Versions: 2018

Failure Type: Non Functioning

Found In Build/Fixed In Build: 313943 /

Priority/Frequency: Normal / Some users will encounter

Locale/System: English / Windows 7 SP1 64-bit

Vote Count: 0

Problem Description:
Trying to map files remotely using Builder.  Able to stop on breakpoints, but when I try to step through the code, the source code is not found, and a null pointer exception occurs in the Eclipse .log.  

Steps to Reproduce:
Try to debug code where the code is on different drive letters on the client and server.  Set breakpoints and Builder stopped on a breakpoint, but error message 'Source not found'. Tried to edit mappings, but didn't work, never found code.  Tried several variations for mappings, including:

Local Path: F:\workspace\appname
Remote Path: G:\dir1\appname
URL: host/dir1/appname

Local Path: \\hostname\G\dir1\appname
Remote Path: G:\dir1\appname
URL: http://host/dir1/appname

Also tried mapping my G drive to the remote drive and still did not work.
Local Path: G:\dir1\appname
Remote Path: G:\dir1\appname

Actual Result:
Error in Eclipse .log file:
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.debug.core".
	at com.adobe.rds.client.eclipse.debugger.core.launching.CFMLSourceLookupParticipant.getSourceName(
	at org.eclipse.debug.core.sourcelookup.AbstractSourceLookupParticipant.findSourceElements(
	at org.eclipse.debug.core.sourcelookup.AbstractSourceLookupDirector$
	at org.eclipse.debug.core.sourcelookup.AbstractSourceLookupDirector.doSourceLookup(
	at org.eclipse.debug.core.sourcelookup.AbstractSourceLookupDirector.getSourceElement(
	at org.eclipse.debug.internal.ui.sourcelookup.SourceLookupFacility.lookup(
	at org.eclipse.debug.internal.ui.sourcelookup.SourceLookupFacility$

Expected Result:
Please catch this error and give some indication as to what is null, so people will have an idea of where the problem is. 

Any Workarounds:
Install Builder on local machine so that mapping isn't necessary.